Обновление NEMНовости 

NEM обновил версию NIS до 0.6.95

Разработчики NEM объявили об очередном обновлении кода пользовательского узла (NIS): изменения коснулись настроек безопасности, условий подключения пользователей с Супернодами, а также были скорректированы выявленные ранее ошибки, увеличена скорость обработки блоков. Кроме того,  увеличено вознаграждение за подтверждение блоков, за счет корректировки минимальной суммы XEM для достижения самой малой степени важности в алгоритме POI c 1000 XEM до 10 XEM. Не путаться с суммой в 10 000 XEM, которая позволяет начать харвестинг!

Предыдущее изменение кода было проведено в октябре 2017 года.

Полный перечень изменений:

1) Запрос на сопряжение с «Элвином»:

Добавляет некоторые новые идентификаторы API в nem.core, поэтому вы можете использовать эти запросы программно.

Обновление версии библиотеки с 1,50 до 1,58.

Обновление версии HttpAsyncClient с 4.1.1 до 4.1.3.

2) Пространства имен и Мозаика:

Исправлены различные ошибки в NIS Api для извлечения пространств имен / мозаики.

Исправлена ошибка, которая позволяет мозаике исчезнуть, если связанное корневое пространство имен было возобновлено в течение льготного периода.

3) Спам-фильтр:

Отдельный фильтр спама транзакций multisig и Non-multisig, они теперь независимы друг от друга.

Повышение вознаграждения. Максимальное повышение важности сейчас достигнуто с 10 XEM, ранее был 1000 xem.

4)Обработка блоков:

Ускоренная обработка блоков, без ненужного копирования.

Из-за новых учетных записей NEM требования к оперативной памяти для NIS становиться выше. Как правило, чем больше Вы выделяете RAM(оперативной памяти) для NIS, тем лучше.

Рекомендовано выделить как минимум 2 ГБ оперативной памяти для NIS.

Владельцы супернод должны ориентироваться на VPS (Virtual Private Server — Виртуальный выделенный сервер) и для этого необходимо не менее 4 ГБ RAM (оперативной памяти) рекомендуем запускать NIS с параметрами —Xms2800M —Xmx2800M.

Вы можете запустить NIS с установщиком по следующей ссылке :https://bob.nem.ninja/nis-0.6.95.tgz

Важно: NEM требует Java 8, которую можно скачать на официальном сайте.

Похожие материалы о NEM: